―ディスタンスベクター型ルーティングプロトコルにおけるスプリットホライズンの問題点の回避

CCstudyのまんまです。本当に勉強になります。

■FRSW
FRSW(config)#frame-relay switching
FRSW(config)#int s2/0
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 120 int s2/1 210
FRSW(config-if)#frame-relay route 130 int s2/2 310
FRSW(config-if)#no shut
FRSW(config-if)#int s2/1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 210 int s2/0 120
FRSW(config-if)#no shut
FRSW(config-if)#int s2/2
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 310 int s2/0 130
FRSW(config-if)#no shut


FRSW#sh frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial2/0 120 Serial2/1 210 inactive
Serial2/0 130 Serial2/2 310 inactive
Serial2/1 210 Serial2/0 120 inactive
Serial2/2 310 Serial2/0 130 inactive


■R2
R2(config)#int s1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#int loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ex
R2(config)#router eigrp 100
R2(config-router)#network 192.168.1.0
R2(config-router)#network 2.0.0.0
R2(config-router)#no auto-summary


■R3
R3(config)#int s2/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ex
R3(config)#router eigrp 100
R3(config-router)#network 192.168.2.0
R3(config-router)#network 3.0.0.0
R3(config-router)#no auto-summary


■R1
R1(config)#int s1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shut
R1(config)#int s1/0.1 point-to-point
R1(config-subif)#ip address 192.168.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 120
R1(config-fr-dlci)#int s1/0.2 point-to-point
R1(config-subif)#ip address 192.168.2.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 130
R1(config)#router eigrp 100
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#no auto-summary


R1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static
Local 2 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0

DLCI = 120, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

input pkts 7 output pkts 79 in bytes 238
out bytes 23336 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 79 out bcast bytes 23336
pvc create time 00:17:12, last time pvc status changed 00:00:31

DLCI = 130, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.2

input pkts 3 output pkts 33 in bytes 102
out bytes 7796 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 32 out bcast bytes 7732
pvc create time 00:17:15, last time pvc status changed 00:00:35


■R1でIPアドレスとDLCIの対応を確認する
R1#sh frame-relay map
Serial1/0.2 (up): point-to-point dlci, dlci 130(0x82,0x2020), broadcast
status defined, active
Serial1/0.1 (up): point-to-point dlci, dlci 120(0x78,0x1C80), broadcast
status defined, active


■R2でIPアドレスとDLCIの対応を確認する
R2#sh frame-relay map
Serial1/0 (up): ip 192.168.1.1 dlci 210(0xD2,0x3420), dynamic,
broadcast,, status defined, active


■R3でIPアドレスとDLCIの対応を確認する
R3#sh frame-relay map
Serial2/0 (up): ip 192.168.2.1 dlci 310(0x136,0x4C60), dynamic,
broadcast,, status defined, active


■R2のルーティングテーブルを確認する
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2809856] via 192.168.1.1, 00:04:56, Serial1/0←R3の先にあるルート情報をR1経由で受け取っています。
C 192.168.1.0/24 is directly connected, Serial1/0
D 192.168.2.0/24 [90/2681856] via 192.168.1.1, 00:05:01, Serial1/0


■R3のルーティングテーブルを確認する
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2809856] via 192.168.2.1, 00:09:32, Serial2/0←R3の先にあるルート情報をR1経由で受け取っています。
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
D 192.168.1.0/24 [90/2681856] via 192.168.2.1, 00:09:34, Serial2/0
C 192.168.2.0/24 is directly connected, Serial2/0


■R2からR3へpingする
R2#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms