出来る限り一括で設定の練習をしたいということで、エリアを2つに分けてネイバー認証まで行えるようにトポロジを書いてみました。
エリア0がシンプルパスワード(平文)、エリア1がMD5認証(暗号化)です。
OSPFのエリア分けをしているので、ルーティングテーブルに「そのルータが参加するエリアとは別のエリア内のネットワークへのルート」を示す「O IA」が表示されていたりして、なかなか面白いシナリオになってると思います。

■R1
R1(config)#int fa0/0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#ex
R1(config)#router ospf 100
R1(config-router)#network 192.168.0.1 0.0.0.0 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#area 0 authentication
R1(config-router)#ex
R1(config)#int fa0/0
R1(config-if)#ip ospf priority 100
R1(config-if)#ip ospf authentication-key cisco
R1(config-if)#ex


■R2
R2(config)#int fa0/0
R2(config-if)#ip address 192.168.0.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#int loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ex
R2(config)#router ospf 100
R2(config-router)#network 192.168.0.2 0.0.0.0 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#area 0 authentication
R2(config-router)#ex
R2(config)#int fa0/0
R2(config-if)#ip ospf priority 0
R2(config-if)#ip ospf authentication-key cisco
R2(config-if)#ex


■R3
R3(config)#int fa0/0
R3(config-if)#ip address 192.168.0.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ex
R3(config)#router ospf 100
R3(config-router)#network 192.168.0.3 0.0.0.0 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#area 0 authentication
R3(config-router)#ex
R3(config)#int fa0/0
R3(config-if)#ip ospf priority 2
R3(config-if)#ip ospf authentication-key cisco
R3(config-if)#end


■R4
R4(config)#int fa0/0
R4(config-if)#ip address 192.168.0.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#int fa0/1
R4(config-if)#ip address 172.31.0.4 255.255.0.0
R4(config-if)#no shut
R4(config-if)#int loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#ex
R4(config)#router ospf 100
R4(config-router)#network 192.168.0.4 0.0.0.0 area 0
R4(config-router)#network 172.31.0.0 0.0.255.255 area 1
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0
R4(config-router)#area 0 authentication
R4(config-router)#area 1 authentication message-digest
R4(config-router)#ex
R4(config)#int fa0/0
R4(config-if)#ip ospf authentication-key cisco
R4(config)#int fa0/1
R4(config-if)#ip ospf message-digest-key 1 md5 cisco
R4(config-if)#ex


■R5
R5(config)#int fa0/0
R5(config-if)#ip address 10.10.10.5 255.255.255.0
R5(config-if)#no shut
R5(config-if)#int fa0/1
R5(config-if)#ip address 172.31.0.5 255.255.0.0
R5(config-if)#no shut
R5(config-if)#int loopback 0
R5(config-if)#ip address 5.5.5.5 255.255.255.0
R5(config-if)#no shut
R5(config-if)#ex
R5(config)#router ospf 100
R5(config-router)#network 10.10.10.5 0.0.0.0 area 1
R5(config-router)#network 172.31.0.0 0.0.255.255 area 1
R5(config-router)#network 5.5.5.5 0.0.0.0 area 1
R5(config-router)#area 1 authentication message-digest
R5(config-router)#passive-interface fa0/0
R5(config-router)#ex
R5(config)#int fa0/1
R5(config-if)#ip ospf message-digest-key 1 md5 cisco
R5(config-if)#ex


■R1のOSPFの設定を確認する
R1#sh ip protocols
Routing Protocol is "ospf 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 1.1.1.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
1.1.1.1 0.0.0.0 area 0
192.168.0.1 0.0.0.0 area 0
Routing Information Sources:
Gateway Distance Last Update
4.4.4.4 110 00:12:59
3.3.3.3 110 00:47:33
2.2.2.2 110 00:47:33
1.1.1.1 110 00:47:33
Distance: (default is 110)


■R1のOSPFインタフェースを確認する
R1#sh ip ospf int fa0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 192.168.0.1/24, Area 0
Process ID 100, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 100
Designated Router (ID) 1.1.1.1, Interface address 192.168.0.1
Backup Designated router (ID) 3.3.3.3, Interface address 192.168.0.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 3, Adjacent neighbor count is 3
Adjacent with neighbor 4.4.4.4
Adjacent with neighbor 3.3.3.3 (Backup Designated Router)
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
Simple password authentication enabled


■R1のOSPFのルータ本体の情報を確認する
R1#sh ip ospf
Routing Process "ospf 100" with ID 1.1.1.1←ルータID
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has simple password authentication←シンプルパスワードを使用している
SPF algorithm executed 14 timesSPFアルゴリズムが実行された回数
Area ranges are
Number of LSA 8. Checksum Sum 0x03FBA9
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0


■R1のネイバーを確認する
R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 1 FULL/DROTHER 00:00:34 192.168.0.4 FastEthernet0/0
3.3.3.3 2 FULL/BDR 00:00:32 192.168.0.3 FastEthernet0/0
2.2.2.2 0 FULL/DROTHER 00:00:39 192.168.0.2 FastEthernet0/0


■R1でトポロジーテーブル(LSDB)を確認する
R1#sh ip ospf database

OSPF Router with ID (1.1.1.1) (Process ID 100)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 1371 0x80000006 0x000636 2
2.2.2.2 2.2.2.2 1262 0x80000006 0x00F539 2
3.3.3.3 3.3.3.3 919 0x80000006 0x00E53C 2
4.4.4.4 4.4.4.4 844 0x8000000C 0x00CC41 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
192.168.0.1 1.1.1.1 1371 0x80000007 0x002075

Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
5.5.5.5 4.4.4.4 591 0x80000002 0x003CD9
10.10.10.0 4.4.4.4 711 0x80000003 0x0012EF
172.31.0.0 4.4.4.4 844 0x80000002 0x00DE80


■R1のルーティングテーブルを確認する
R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 192.168.0.2, 00:49:15, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 192.168.0.3, 00:49:15, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 192.168.0.4, 00:49:15, FastEthernet0/0
5.0.0.0/32 is subnetted, 1 subnets
O IA 5.5.5.5 [110/3] via 192.168.0.4, 00:44:29, FastEthernet0/0
O IA 172.31.0.0/16 [110/2] via 192.168.0.4, 00:49:16, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.10.10.0 [110/12] via 192.168.0.4, 00:14:41, FastEthernet0/0
C 192.168.0.0/24 is directly connected, FastEthernet0/0


■R5のOSPFの設定を確認する
R5#sh ip protocols
Routing Protocol is "ospf 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 5.5.5.5
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
5.5.5.5 0.0.0.0 area 1
10.10.10.5 0.0.0.0 area 1
172.31.0.0 0.0.255.255 area 1
Reference bandwidth unit is 100 mbps
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
4.4.4.4 110 00:21:41
Distance: (default is 110)


■R5のOSPFインタフェースを確認する
R5#sh ip ospf int
Loopback0 is up, line protocol is up
Internet Address 5.5.5.5/24, Area 1
Process ID 100, Router ID 5.5.5.5, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
FastEthernet0/0 is up, line protocol is up
Internet Address 10.10.10.5/24, Area 1
Process ID 100, Router ID 5.5.5.5, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 5.5.5.5, Interface address 10.10.10.5
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
No Hellos (Passive interface)
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
No key configured, using default key id 0
FastEthernet0/1 is up, line protocol is up
Internet Address 172.31.0.5/16, Area 1
Process ID 100, Router ID 5.5.5.5, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 5.5.5.5, Interface address 172.31.0.5
Backup Designated router (ID) 4.4.4.4, Interface address 172.31.0.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:00
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 4.4.4.4 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
Youngest key id is 1


■R5のOSPFのルータ本体の情報を確認する
R5#sh ip ospf
Routing Process "ospf 100" with ID 5.5.5.5
Start time: 00:12:40.924, Time elapsed: 00:58:21.704
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
Area 1
Number of interfaces in this area is 3 (1 loopback)
Area has message digest authenticationMD5認証
SPF algorithm last executed 00:24:26.876 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 8. Checksum Sum 0x04B92A
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0


■R5のネイバーを確認する
R5#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 1 FULL/BDR 00:00:33 172.31.0.4 FastEthernet0/1


■R5でトポロジーテーブル(LSDB)を確認する
R5#sh ip ospf database

OSPF Router with ID (5.5.5.5) (Process ID 100)

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count
4.4.4.4 4.4.4.4 1464 0x80000005 0x00B2BA 1
5.5.5.5 5.5.5.5 1588 0x80000006 0x00DD29 3

Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
172.31.0.5 5.5.5.5 1366 0x80000002 0x000E22

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
1.1.1.1 4.4.4.4 1717 0x80000002 0x00F431
2.2.2.2 4.4.4.4 1717 0x80000002 0x00C65B
3.3.3.3 4.4.4.4 1717 0x80000002 0x009885
4.4.4.4 4.4.4.4 1717 0x80000002 0x0060BA
192.168.0.0 4.4.4.4 1717 0x80000002 0x00675A


■R5のルーティングテーブルを確認する
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/3] via 172.31.0.4, 00:27:29, FastEthernet0/1
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/3] via 172.31.0.4, 00:27:29, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/3] via 172.31.0.4, 00:27:29, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
O IA 4.4.4.4 [110/2] via 172.31.0.4, 00:27:29, FastEthernet0/1
5.0.0.0/24 is subnetted, 1 subnets
C 5.5.5.0 is directly connected, Loopback0
C 172.31.0.0/16 is directly connected, FastEthernet0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, FastEthernet0/0
O IA 192.168.0.0/24 [110/2] via 172.31.0.4, 00:27:31, FastEthernet0/1


■R5にパッシブインタフェースが設定されているか確認する
R5#sh ip protocols
Routing Protocol is "ospf 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 5.5.5.5
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
5.5.5.5 0.0.0.0 area 1
10.10.10.5 0.0.0.0 area 1
172.31.0.0 0.0.255.255 area 1
Reference bandwidth unit is 100 mbps
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
4.4.4.4 110 00:18:44
Distance: (default is 110)


■10.10.10.100/24から192.168.0.1/24にping
C:\Documents and Settings\10.10.10.100>ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:

Reply from 192.168.0.1: bytes=32 time=7ms TTL=155
Reply from 192.168.0.1: bytes=32 time=2ms TTL=155
Reply from 192.168.0.1: bytes=32 time=2ms TTL=155
Reply from 192.168.0.1: bytes=32 time=2ms TTL=155

Ping statistics for 192.168.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 7ms, Average = 3ms