■R3_3640A
conf t
!
ipv6 unicast-routing
!
interface Tunnel1
ipv6 address 2001:10:10:10::/64 eui-64
no ipv6 nd suppress-ra
tunnel source fa0/0
tunnel mode ipv6ip isatap
!
interface FastEthernet0/0
ip address 192.168.1.253 255.255.255.0
no shut
!
end



■ISATAPトンネルインターフェイスの状態を確認
R3_3640A#sh ipv6 int tunnel1
Tunnel1 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::5EFE:C0A8:1FD
Global unicast address(es):
2001:10:10:10:0:5EFE:C0A8:1FD, subnet is 2001:10:10:10::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FFA8:1FD
MTU is 1480 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is not supported
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements live for 1800 seconds
Hosts use stateless autoconfig for addresses.



■workstation
C:\>netsh interface ipv6 install
OK

C:\>netsh interface ipv6 isatap set router 192.168.1.253
OK

C:\>ipconfig

Windows IP Configuration


Ethernet adapter ローカル エリア接続:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.4
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::21d:72ff:fe90:f3e6%7
Default Gateway . . . . . . . . . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%4
Default Gateway . . . . . . . . . :

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 2001:10:10:10:0:5efe:192.168.1.4
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.4%2
Default Gateway . . . . . . . . . : fe80::5efe:192.168.1.253%2


C:\>ping 2001:10:10:10:0:5efe:c0a8:1fd

Pinging 2001:10:10:10:0:5efe:192.168.1.253 with 32 bytes of data:

Reply from 2001:10:10:10:0:5efe:192.168.1.253: time=3ms
Reply from 2001:10:10:10:0:5efe:192.168.1.253: time=2ms
Reply from 2001:10:10:10:0:5efe:192.168.1.253: time=2ms
Reply from 2001:10:10:10:0:5efe:192.168.1.253: time=2ms

Ping statistics for 2001:10:10:10:0:5efe:192.168.1.253:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 3ms, Average = 2ms

C:\>


■R3_3640A
conf t
!
ipv6 unicast-routing
!
interface Tunnel1
ipv6 unnumbered Loopback0
tunnel source fa0/0
tunnel mode ipv6ip 6to4
!
interface Loopback0
ipv6 address 2002:c0a8:0101:1::1/64
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shut
!
ipv6 route 2002::/16 tunnel1
!
end


■R4_3640
conf t
!
ipv6 unicast-routing
!
interface Tunnel1
ipv6 unnumbered Loopback0
tunnel source fa0/0
tunnel mode ipv6ip 6to4
!
interface Loopback0
ipv6 address 2002:c0a8:0102:1::2/64
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
no shut
!
ipv6 route 2002::/16 tunnel1
!
end



■R3のルーティングテーブルを確認する
R3_3640A#sh ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S 2002::/16 [1/0]
via ::, Tunnel1
C 2002:C0A8:101:1::/64 [0/0]
via ::, Loopback0
L 2002:C0A8:101:1::1/128 [0/0]
via ::, Loopback0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0


■R4のルーティングテーブルを確認する
R4_3640#sh ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S 2002::/16 [1/0]
via ::, Tunnel1
C 2002:C0A8:102:1::/64 [0/0]
via ::, Loopback0
L 2002:C0A8:102:1::2/128 [0/0]
via ::, Loopback0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0


■R4のipv6アドレス宛にping
R3_3640A#ping 2002:c0a8:0102:1::2 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:C0A8:102:1::2, timeout is 2 seconds:
Packet sent with a source address of 2002:C0A8:101:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms


■R3_3640A
conf t
!
ipv6 unicast-routing
!
interface Tunnel0
ipv6 unnumbered Loopback0
ipv6 rip RIPng enable
tunnel source 192.168.1.1
tunnel destination 192.168.1.2
tunnel mode ipv6ip
!
interface Loopback0
ipv6 address 2001:1:2:3::1/64
ipv6 rip RIPng enable
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shut
!
ipv6 router rip RIPng
!
end


■R4_3640
conf t
!
ipv6 unicast-routing
!
interface Tunnel0
ipv6 unnumbered Loopback0
ipv6 rip RIPng enable
tunnel source 192.168.1.2
tunnel destination 192.168.1.1
tunnel mode ipv6ip
!
interface Loopback0
ipv6 address 2001:100:200:300::2/64
ipv6 rip RIPng enable
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
no shut
!
ipv6 router rip RIPng
!
end


■トンネルを確認する
R3_3640A#sh int tunnel0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 192.168.1.1, destination 192.168.1.2
Tunnel protocol/transport IPv6/IP
Tunnel TTL 255
Fast tunneling enabled
Tunnel transmit bandwidth 8000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
Last input 00:00:29, output 00:00:03, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
116 packets input, 13008 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
124 packets output, 11440 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out


■ルーティングテーブルを確認する
R3_3640A#sh ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001:1:2:3::/64 [0/0]
via ::, Loopback0
L 2001:1:2:3::1/128 [0/0]
via ::, Loopback0
R 2001:100:200:300::/64 [120/2]
via FE80::C0A8:102, Tunnel0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0


■対向ルータが周知している経路宛てにping
R3_3640A#ping 2001:100:200:300::2 source loopback0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:100:200:300::2, timeout is 2 seconds:
Packet sent with a source address of 2001:1:2:3::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms

Catalyst3750のIOSバックアップです。
・tftpサーバとして3CDaemon(192.168.1.100)を使用
・sh flashIOSディレクトリを確認して、ディレクトリ名の後に「.tar」を付加する


Switch#sh flash

Directory of flash:/

3 -rwx 1048 Mar 1 1993 00:01:40 +00:00 multiple-fs
5 drwx 192 Mar 1 1993 01:14:53 +00:00 c3750-ipservicesk9-mz.122-55.SE5


Switch#archive upload-sw tftp://192.168.1.100/c3750-ipservicesk9-mz.122-55.SE5.tar
!
System software to be uploaded:
System Type: 0x00000000!
archiving c3750-ipservicesk9-mz.122-55.SE5 (directory)
archiving c3750-ipservicesk9-mz.122-55.SE5/html (directory)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/layers.js (1616 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/topbannernofpv.shtml (18990 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/stylesheet.css (22059 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/appsui.js (1749 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/frmwrkResource.htm (950 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/more.txt (62 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/preflight.js (17300 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/xsetup.js (71429 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en (directory)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/re_framework.js (6052 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/troubleshooting_Browser.htm (3477 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/re_xsetup.js (23012 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/charset.js (333 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/re_fpv_title.js (3795 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/troubleshooting_OS.htm (2891 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/re_preflight.js (3853 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/en/troubleshooting_JavaScript.htm (8346 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/setup_report.htm (12811 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/empty.htm (313 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/reloadstatus.shtml (846 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/charset.js (333 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/helpframework.js (865 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/title.js (577 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/back.htm (515 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help (directory)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help/help.htm (900 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help/xsetup_help.htm (896 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help/xsetstd.htm (22902 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help/xsetinit.htm (16624 bytes)!
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help/xsetip.htm (6314 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/help/helptoolbar.shtml (9571 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/toolbar.js (6383 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images (directory)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_button_left.gif (298 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/informational16.gif (1045 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/up_arrow.gif (837 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/question.gif (405 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/ip_fig1.gif (7769 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/tab_bg_active.gif (827 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/tab_left_inactive.gif (919 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/spacer.gif (49 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbarButtonDownLeft.gif (187 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_back.gif (908 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/warning_big.gif (296 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/top_left.gif (45 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/down_arrow.gif (837 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/top_right.gif (45 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/bottom_left.gif (45 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbarGradient3px.gif (519 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_help.gif (1077 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbarButtonDownRight.gif (188 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbarButtonDownTile.gif (157 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbarGradient.gif (262 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/swrefresh.gif (773 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/confirm.gif (515 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/tab_bg_inactive.gif (931 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/logo.gif (1706 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_button_right.gif (295 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_forward.gif (906 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/fatal_error_big.gif (271 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_refresh.gif (1189 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/tab_right_inactive.gif (922 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/ip_fig2.gif (7003 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/tab_right_active.gif (862 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_button_tile.gif (160 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/toolbar_print.gif (1183 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/tab_left_active.gif (852 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/images/bottom_right.gif (45 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/bottombanner.htm (4108 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/nsback.htm (519 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/xsetup.shtml (107031 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/express-setup.htm (6825 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/sitewide.js (12467 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/framework.js (25715 bytes)!
archiving c3750-ipservicesk9-mz.122-55.SE5/html/sorttable.js (48234 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/forms.js (13756 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/html/xhome.htm (6960 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5/c3750-ipservicesk9-mz.122-55.SE5.bin (13006601 bytes)!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
archiving c3750-ipservicesk9-mz.122-55.SE5/info (698 bytes)
archiving c3750-ipservicesk9-mz.122-55.SE5 (directory)
archiving c3750-ipservicesk9-mz.122-55.SE5/info (700 bytes)
archiving info (111 bytes)
Switch#

Windows Server2003でのRADIUSサーバの実装です。

・認証サーバ=RADIUSサーバ
・オーセンティケータ=Catalyst2950
サプリカントWindows XPにデフォルトで搭載


■ユーザー:山田 太郎
ユーザーID:yamada@example.local
パスワード:ccna.com2008



■認証サーバ=RADIUSサーバの設定









ここではフレンドリ名に、分かりやすい名前
クライアントのアドレスにオーセンティケータのIPアドレスを入力する
スイッチをオーセンティケータとして指定する場合には、スイッチに管理用IPアドレスを設定する必要がある。




ここではオーセンティケータと交換する文字列を入力する
文字列は双方で一致しなくてはならない
文字列:cisco




















MD5認証用にパスワードをリセットする
パスワード:ccna.com2008


■オーセンティケータ=Catalyst2950の設定
Switch(config)#hostname Switch_A
Switch_A(config)#aaa new-model
Switch_A(config)#aaa authentication dot1x default group radius
Switch_A(config)#dot1x system-auth-control
Switch_A(config)#int fa0/1
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#dot1x port-control auto
Switch_A(config-if)#int vlan 1
Switch_A(config-if)#ip address 192.168.0.50 255.255.255.0
Switch_A(config-if)#no shut
Switch_A(config-if)#exit
Switch_A(config)#radius-server host 192.168.0.200 auth-port 1812 acct-port 1813 key cisco


サプリカントWindows XPにデフォルトで搭載の設定

Windows XP Service Pack3では、認証タブが隠されている。
認証タブを表示するには、サービスのWired AutoConfigを開始する




パスワード:ccna.com2008

CCstudyを参考にしています。
というか同じです。
http://www.ccstudy.org/labtech/terminalserver/terminalserver.html

■TS
Router(config)#hostname TS
TS(config)#ip host R1 2001 1.1.1.1
TS(config)#int loopback 0
TS(config-if)#ip address 1.1.1.1 255.255.255.0
TS(config-if)#exit
TS(config)#line 1 16
TS(config-line)#no exec
TS(config-line)#transport input all
TS(config-line)#exit
TS(config)#exit
TS#
TS#R1
Trying R1 (1.1.1.1, 2001)... Open

R1111>en
R1111#

TS#sh sessions
Conn Host Address Byte Idle Conn Name
* 1 R1 1.1.1.1 0 0 R1

TS#disconnect 1
Closing connection to R1 [confirm]
TS#sh sessions
% No connections open